]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/classes/cpan.bbclass
gnutls: bump PR. don't use _prepend for do_configure.
[familiar-h63xx-build.git] / org.handhelds.familiar / classes / cpan.bbclass
1 FILES_${PN} += '${libdir}/perl5'
2
3 cpan_do_configure () {
4         perl Makefile.PL
5         if [ "${BUILD_SYS}" != "${HOST_SYS}" ]; then
6                 . ${STAGING_DIR}/${TARGET_SYS}/perl/config.sh
7                 sed -e "s:\(SITELIBEXP = \).*:\1${sitelibexp}:; s:\(SITEARCHEXP = \).*:\1${sitearchexp}:; s:\(INSTALLVENDORLIB = \).*:\1${D}${libdir}/perl5:; s:\(INSTALLVENDORARCH = \).*:\1${D}${libdir}/perl5:" < Makefile > Makefile.new
8                 mv Makefile.new Makefile
9         fi
10 }
11
12 cpan_do_compile () {
13         oe_runmake PASTHRU_INC="${CFLAGS}"
14 }
15
16 cpan_do_install () {
17         oe_runmake install_vendor
18 }
19
20 EXPORT_FUNCTIONS do_configure do_compile do_install