]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/classes/gettext.bbclass
gnutls: bump PR. don't use _prepend for do_configure.
[familiar-h63xx-build.git] / org.handhelds.familiar / classes / gettext.bbclass
1 python () {
2         # Remove the NLS bits if USE_NLS is no.
3         if bb.data.getVar('USE_NLS', d, 1) == 'no':
4                 cfg = oe_filter_out('^--(dis|en)able-nls$', bb.data.getVar('EXTRA_OECONF', d, 1) or "", d)
5                 cfg += " --disable-nls"
6                 depends = bb.data.getVar('DEPENDS', d, 1) or ""
7                 bb.data.setVar('DEPENDS', oe_filter_out('^(virtual/libiconv|virtual/libintl)$', depends, d), d)
8                 bb.data.setVar('EXTRA_OECONF', cfg, d)
9 }
10
11 DEPENDS =+ "gettext-native"
12 EXTRA_OECONF += "--enable-nls"