]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/classes/linux_modules.bbclass
gnutls: bump PR. don't use _prepend for do_configure.
[familiar-h63xx-build.git] / org.handhelds.familiar / classes / linux_modules.bbclass
1 def get_kernelmajorversion(p):
2         import re
3         r = re.compile("([0-9]+\.[0-9]+).*")
4         m = r.match(p);
5         if m:
6                 return m.group(1)
7         return None
8
9 def linux_module_packages(s, d):
10         import bb, os.path
11         suffix = ""
12         if (bb.data.getVar("PARALLEL_INSTALL_MODULES", d, 1) == "1"):
13                 file = bb.data.expand('${STAGING_KERNEL_DIR}/kernel-abiversion', d)
14                 if (os.path.exists(file)):
15                      suffix = "-%s" % (get_kernelmajorversion(base_read_file(file)))
16         return " ".join(map(lambda s: "kernel-module-%s%s" % (s.lower().replace('_', '-').replace('@', '+'), suffix), s.split()))
17
18 # that's all
19