]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/classes/native.bbclass
gnutls: bump PR. don't use _prepend for do_configure.
[familiar-h63xx-build.git] / org.handhelds.familiar / classes / native.bbclass
1 inherit base
2
3 # Native packages are built indirectly via dependency,
4 # no need for them to be a direct target of 'world'
5 EXCLUDE_FROM_WORLD = "1"
6
7 PACKAGES = ""
8
9 TARGET_ARCH = "${BUILD_ARCH}"
10 TARGET_OS = "${BUILD_OS}"
11 TARGET_VENDOR = "${BUILD_VENDOR}"
12 TARGET_PREFIX = "${BUILD_PREFIX}"
13 TARGET_CC_ARCH = "${BUILD_CC_ARCH}"
14
15 HOST_ARCH = "${BUILD_ARCH}"
16 HOST_OS = "${BUILD_OS}"
17 HOST_VENDOR = "${BUILD_VENDOR}"
18 HOST_PREFIX = "${BUILD_PREFIX}"
19 HOST_CC_ARCH = "${BUILD_CC_ARCH}"
20
21 CPPFLAGS = "${BUILD_CPPFLAGS}"
22 CFLAGS = "${BUILD_CFLAGS}"
23 CXXFLAGS = "${BUILD_CFLAGS}"
24 LDFLAGS = "${BUILD_LDFLAGS}"
25
26 # Path prefixes
27 base_prefix = "${exec_prefix}"
28 prefix = "${STAGING_DIR}"
29 exec_prefix = "${STAGING_DIR}/${BUILD_ARCH}-${BUILD_OS}"
30
31 # Base paths
32 base_bindir = "${base_prefix}/bin"
33 base_sbindir = "${base_prefix}/bin"
34 base_libdir = "${base_prefix}/lib"
35
36 # Architecture independent paths
37 sysconfdir = "${prefix}/etc"
38 sharedstatedir = "${prefix}/com"
39 localstatedir = "${prefix}/var"
40 infodir = "${datadir}/info"
41 mandir = "${datadir}/man"
42 docdir = "${datadir}/doc"
43 servicedir = "${prefix}/srv"
44
45 # Architecture dependent paths
46 bindir = "${exec_prefix}/bin"
47 sbindir = "${exec_prefix}/bin"
48 libexecdir = "${exec_prefix}/libexec"
49 libdir = "${exec_prefix}/lib"
50 includedir = "${exec_prefix}/include"
51 oldincludedir = "${exec_prefix}/include"
52
53 # Datadir is made arch dependent here, primarily
54 # for autoconf macros, and other things that
55 # may be manipulated to handle crosscompilation
56 # issues.
57 datadir = "${exec_prefix}/share"
58
59 do_stage () {
60         if [ "${INHIBIT_NATIVE_STAGE_INSTALL}" != "1" ]
61         then
62                 oe_runmake install
63         fi
64 }
65
66 do_install () {
67         true
68 }