]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/classes/qpf.bbclass
gnutls: bump PR. don't use _prepend for do_configure.
[familiar-h63xx-build.git] / org.handhelds.familiar / classes / qpf.bbclass
1 PACKAGE_ARCH = "all"
2
3 do_configure() {
4         :
5 }
6
7 do_compile() {
8         :
9 }
10
11 pkg_postinst_fonts() {
12 #!/bin/sh
13 set -e
14 . /etc/profile
15 ${sbindir}/update-qtfontdir
16 }
17
18 pkg_postrm_fonts() {
19 #!/bin/sh
20 set -e
21 . /etc/profile
22 ${sbindir}/update-qtfontdir -f
23 }
24
25 python populate_packages_prepend() {
26         postinst = bb.data.getVar('pkg_postinst_fonts', d, 1)
27         postrm   = bb.data.getVar('pkg_postrm_fonts', d, 1)
28         fontdir  = bb.data.getVar('palmtopdir', d, 1) + '/lib/fonts'
29         pkgregex = "^([a-z-]*_[0-9]*).*.qpf$"
30         pkgpattern = bb.data.getVar('QPF_PKGPATTERN', d, 1) or 'qpf-%s'
31         pkgdescription = bb.data.getVar('QPF_DESCRIPTION', d, 1) or 'QPF font %s'
32
33         do_split_packages(d, root=fontdir, file_regex=pkgregex, output_pattern=pkgpattern, 
34                           description=pkgdescription, postinst=postinst, postrm=postrm, recursive=True, hook=None, 
35                           extra_depends='qpf-font-common')
36 }