]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/classes/sdl.bbclass
gnutls: bump PR. don't use _prepend for do_configure.
[familiar-h63xx-build.git] / org.handhelds.familiar / classes / sdl.bbclass
1 FILES_${PN} += '${libdir}/perl5'
2
3 sdl_do_configure () {
4         if [ -x ${S}/configure ] ; then
5                 cfgcmd="${S}/configure \
6                     -GL -GLU"
7                 oenote "Running $cfgcmd..."
8                 $cfgcmd || oefatal "oe_runconf failed"
9                 if [ "${BUILD_SYS}" != "${HOST_SYS}" ]; then
10                         . ${STAGING_DIR}/${TARGET_SYS}/perl/config.sh
11                         sed -e "s:\(SITELIBEXP = \).*:\1${sitelibexp}:; s:\(SITEARCHEXP = \).*:\1${sitearchexp}:; s:\(INSTALLVENDORLIB = \).*:\1${D}${libdir}/perl5:; s:\(INSTALLVENDORARCH = \).*:\1${D}${libdir}/perl5:" < Makefile > Makefile.new
12                         mv Makefile.new Makefile
13                 fi
14         else
15                 oefatal "no configure script found"
16         fi
17 }
18
19 sdl_do_compile () {
20         oe_runmake PASTHRU_INC="${CFLAGS}"
21 }
22
23 sdl_do_install () {
24         oe_runmake install_vendor
25 }
26
27 EXPORT_FUNCTIONS do_configure do_compile do_install