]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/classes/srec.bbclass
gnutls: bump PR. don't use _prepend for do_configure.
[familiar-h63xx-build.git] / org.handhelds.familiar / classes / srec.bbclass
1 #
2 # Creates .srec files from images.
3 #
4 # Useful for loading with Yamon.
5
6 # Define SREC_VMAADDR in your machine.conf.
7
8 SREC_CMD = "${TARGET_PREFIX}objcopy -O srec -I binary --adjust-vma ${SREC_VMAADDR} ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.${type} ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.${type}.srec"
9
10 # Do not build srec files for these types of images:
11 SREC_SKIP = "tar"
12
13 do_srec () {
14     if [ ${SREC_VMAADDR} = "" ] ; then
15        oefatal Cannot do_srec without SREC_VMAADDR defined.
16     fi
17     for type in ${IMAGE_FSTYPES}; do
18         for skiptype in ${SREC_SKIP}; do
19             if [ $type = $skiptype ] ; then continue 2 ; fi
20         done
21         ${SREC_CMD}
22     done
23     return 0
24 }
25
26 addtask srec after do_rootfs before do_build