]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/classes/xfce.bbclass
gnutls: bump PR. don't use _prepend for do_configure.
[familiar-h63xx-build.git] / org.handhelds.familiar / classes / xfce.bbclass
1 # xfce.oeclass
2 # Copyright (C) 2004, Advanced Micro Devices, Inc.  All Rights Reserved
3 # Released under the MIT license (see packages/COPYING)
4
5 # Global class to make it easier to maintain XFCE packages
6
7 HOMEPAGE = "http://www.xfce.org"
8 LICENSE = "LGPL-2"
9
10 SRC_URI = "http://www.us.xfce.org/archive/xfce-${PV}/src/${PN}-${PV}.tar.gz"
11
12 inherit autotools
13
14 EXTRA_OECONF += "--with-pluginsdir=${libdir}/xfce4/panel-plugins/"
15
16 # FIXME:  Put icons in their own package too?
17
18 FILES_${PN} += "${datadir}/icons/* ${datadir}/applications/* ${libdir}/xfce4/modules/*.so*"
19 FILES_${PN}-doc += "${datadir}/xfce4/doc"