]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/abiword/abiword_2.4.2.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / abiword / abiword_2.4.2.bb
1 DESCRIPTION ="AbiWord is free word processing program similar to Microsoft(r) Word""
2 HOMEPAGE="http://www.abiword.org""
3 MAINTAINER="Koen Kooi <koen@handhelds.org>"
4 LICENSE="GPLv2"
5
6 DEPENDS     = "cdump-native libgsf libgnomeprint libgnomeprintui libglade libfribidi enchant jpeg libpng perl glibc libxml2"
7 RDEPENDS    = "enchant glibc-gconv-ibm850 glibc-gconv-cp1252 \
8                glibc-gconv-iso8859-15 glibc-gconv-iso8859-1"
9 PR="r0"
10
11 SRC_URI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz \
12         file://cdump-hack.patch;patch=1"
13 S = "${WORKDIR}/abiword-${PV}/abi"
14
15 FILES_${PN} += " ${datadir}/icons/* \
16 ${datadir}/AbiSuite-2.4/AbiWord/glade \
17 ${datadir}/AbiSuite-2.4/AbiWord/scripts \
18 ${datadir}/AbiSuite-2.4/AbiWord/system.profile-en \
19 ${datadir}/AbiSuite-2.4/AbiWord/system.profile-en_GB \
20 #${datadir}/AbiSuite-2.4/templates/A4.awt \
21 #${datadir}/AbiSuite-2.4/templates/US-Letter.awt \
22 ${datadir}/AbiSuite-2.4/templates/normal.awt \
23 ${datadir}/AbiSuite-2.4/templates/normal.awt-en_GB \
24 ${datadir}/AbiSuite-2.4/templates/Employee-Directory.awt \
25 ${datadir}/AbiSuite-2.4/templates/Business-Report.awt \
26 ${datadir}/AbiSuite-2.4/templates/Fax-Coversheet.awt \
27 ${datadir}/AbiSuite-2.4/templates/Resume.awt \
28 ${datadir}/AbiSuite-2.4/templates/Two-Columns.awt \
29 ${datadir}/AbiSuite-2.4/templates/Memo.awt \
30 ${datadir}/AbiSuite-2.4/templates/Press-Release.awt "
31
32 inherit autotools
33
34 #abiword needs this native tool
35 export BUILD_CDUMPTOOL="${STAGING_BINDIR}/cdump"
36
37 PARALLEL_MAKE=""
38
39 do_configure () {
40         cd ${S}
41         ./autogen.sh
42         ./configure --prefix=/usr --host=${TARGET_SYS} --disable-pspell --enable-enchant
43 #       --enable-debug
44         cp -f ${STAGING_BINDIR}/cdump src/tools/cdump/xp/
45 }
46
47 do_install_append() {
48         install -d ${D}${datadir}/pixmaps/
49         mv ${D}${datadir}/icons/* ${D}${datadir}/pixmaps/
50 }
51
52