]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/alsa/alsa-lib_1.0.8.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / alsa / alsa-lib_1.0.8.bb
1 DESCRIPTION = "Alsa sound library"
2 MAINTAINER = "Lorn Potter <lpotter@trolltech.com>"
3 SECTION = "libs/multimedia"
4 LICENSE = "GPL"
5 PR = "r1"
6
7 # configure.in sets -D__arm__ on the command line for any arm system
8 # (not just those with the ARM instruction set), this should be removed,
9 # (or replaced by a permitted #define).
10 #FIXME: remove the following
11 ARM_INSTRUCTION_SET = ""
12
13 SRC_URI = "ftp://ftp.alsa-project.org/pub/lib/alsa-lib-${PV}.tar.bz2"
14
15 inherit autotools pkgconfig
16
17 EXTRA_OECONF = "--with-cards=pdaudiocf --with-oss=yes"
18
19 do_stage () {
20         oe_libinstall -so -C src libasound ${STAGING_LIBDIR}/
21         install -d ${STAGING_INCDIR}/alsa/sound
22         install -m 0644 include/*.h ${STAGING_INCDIR}/alsa/
23         install -m 0644 include/sound/ainstr*.h ${STAGING_INCDIR}/alsa/sound/
24         install -d ${STAGING_DATADIR}/aclocal
25         install -m 0644 utils/alsa.m4 ${STAGING_DATADIR}/aclocal/
26 }
27
28 PACKAGES = "libasound alsa-server alsa-conf alsa-doc alsa-dev"
29 FILES_libasound = "${libdir}/libasound.so*"
30 FILES_alsa-server = "${bindir}"
31 FILES_alsa-conf = "${datadir}"
32 FILES_alsa-dev = "${libdir}/pkgconfig/ ${incdir}"
33