]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/antlr/antlr_2.7.5.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / antlr / antlr_2.7.5.bb
1 DESCRIPTION = "ANother Tool for Language Recognition, (formerly PCCTS) is a \
2 language tool that provides a framework for constructing recognizers, \
3 compilers, and translators from grammatical descriptions containing \
4 Java, C#, C++, or Python actions."
5 LICENSE = "PD"
6 MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
7 PRIORITY = "optional"
8 SECTION = "devel"
9 # DEPENDS += "virtual/java"
10 RDEPENDS += "java-virtual-machine"
11
12 SRC_URI = "http://www.antlr.org/download/antlr-${PV}.tar.gz \
13            file://install.patch;patch=1"
14 S = "${WORKDIR}/antlr-${PV}"
15
16 inherit autotools
17
18 EXTRA_OECONF += "--disable-java --enable-cxx \
19                  --disable-python --disable-csharp \
20                  --disable-verbose --disable-examples"
21
22 do_configure () {
23         if [ ! -e acinclude.m4 ]; then
24                 mv aclocal.m4 acinclude.m4
25         fi
26         autotools_do_configure
27 }