]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/appweb/appweb_1.2.0.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / appweb / appweb_1.2.0.bb
1 DESCRIPTION = "AppWeb is an embedded HTTP Web server that has been designed with security in mind."
2 SECTION = "console/network"
3 LICENSE="GPL"
4 SRC_URI = "http://www.mbedthis.com/software/appWeb-src-1.2.0-1.tar.gz \
5            file://makerules.patch;patch=1 \
6            file://nonrootinstall.patch;patch=1"
7 S = "${WORKDIR}/appWeb-1.2.0"
8
9 APPWEB_HOST = "${@get_appweb_host(d, bb)}"
10 APPWEB_BUILD = "${BUILD_SYS}"
11
12 def get_appweb_host(d, bb):
13     host = bb.data.getVar('HOST_SYS', d, 1)
14     return host.replace('-linux-uclibc', '-linux')
15     
16
17 #  --buildNumber=NUMBER     Set the build number part of the version (1.0.0.X).
18 #  --name=NAME              Set the full product name (BLD_NAME define).
19 #  --port=PORT              Set the default HTTP port to use for the product.
20 #  --product=NAME           Set the one word (no spaces) name of the product.
21 #  --setLibVersion=X.X.X    Set the shared library version number.
22 #  --setVersion=X.X.X       Set the product version number.
23 #  --sslPort=PORT           Set the default SSL port to use for the product.
24 #  --type=BUILD             Set the build type (DEBUG|RELEASE).
25 #
26 #  --enable-access-log      Enable logging of requests to the AppWeb access log.
27 #  --enable-assert          Build with assert checking.
28 #  --enable-config          Build with the ability to parse Apache-style config
29 #  --enable-cookie          Build with cookie handling support.
30 #  --enable-digest-auth     Build with digest authentication support.
31 #  --enable-fast-malloc     Build with the Mbedthis fast malloc.
32 #  --enable-if-modified     Build with HTTP If-Modified checking.
33 #  --enable-keep-alive      Build with HTTP Keep-Alive support.
34 #  --enable-log             Build with the AppWeb trace log facility.
35 #  --enable-modules         Build with the dynamically loaded modules capability.
36 #  --enable-multi-thread    Build AppWeb multi-threaded.
37 #  --disable-multi-thread   Build AppWeb single threaded.
38 #  --enable-rom-fs          Build with the ability to load web pages from ROM.
39 #  --enable-run-as-service  Build with the ability to run as a service/daemon.
40 #  --disable-run-as-service Do not include the ability to run as a service.
41 #  --enable-safe-strings    Enforce safe string handling.
42 #  --enable-session         Build with HTTP session support.
43 #  --enable-shared          Build an appWeb shared library and program. [default]
44 #  --enable-shared-libc     Link with the shared versions of libc.
45 #  --disable-shared-libc    Link with the static versions of libc.
46 #  --enable-squeeze         Build in squeeze mode for minimal memory footprint.
47 #  --disable-squeeze        Build for speed.
48 #  --enable-static          Build a static appWeb library and program. [default]
49 #  --disable-static         Do not build a static appWeb library and program.
50 #
51 #  --with-admin             Include the admin handler.
52 #  --with-auth              Include the authorization handler.
53 #  --with-c_api             Include the C API.
54 #  --with-cgi               Include the CGI handler.
55 #  --with-gacompat          Include GoAhead WebServer API compatibility.
56 #  --with-copy              Build support for the copy handler.
57 #  --with-egi               Include the EGI handler.
58 #  --with-esp               Include the ESP handler.
59 #  --with-ssl               Build support for the SSL protocol.
60 #  --with-upload            Build with the file upload handler
61 #  --with-xdb               Build with XDB 
62 #  Supported PACKAGE names: openssl, php4, php5
63 #  --with-PACKAGE=[builtin|, module]       
64 #                           Include support for the PACKAGE. Link into appWeb 
65 #                           statically and/or build as a module
66 #  --with-PACKAGE-dir=DIR   Set the source directory of the package
67 #  --with-PACKAGE-libs=libs Set a list of libraries to use when linking with
68 #                             the PACKAGE
69 #  --without-PACKAGE        Do not include support for the PACKAGE
70 EXTRA_OECONF = "--prefix=${prefix} \
71                 --docDir=${docdir}/${P} \
72                 --incDir=${includedir} \
73                 --libDir=${libdir} \
74                 --sbinDir=${sbindir} \
75                 --webDir=${localstatedir}/www \
76                 --build=${APPWEB_BUILD} \
77                 --host=${APPWEB_HOST} \
78                 --enable-keep-alive \
79                 --enable-multi-thread \
80                 --with-cgi=builtin \
81                 --enable-cookie \
82                 --enable-config \
83                 --enable-digest-auth \
84                 --without-ssl"
85
86 export IFLAGS = "${CPPFLAGS}"
87 export CC_FOR_BUILD = "${BUILD_CC}"
88 export LD_FOR_BUILD = "${BUILD_LD}"
89
90 LD_LIBRARY_PATH_prepend = "${S}/lib:"
91 LD_LIBRARY_PATH[export] = "1"
92 do_configure () {
93         ./configure ${EXTRA_OECONF}
94 }
95
96 do_compile () {
97         oe_runmake build
98         oe_runmake compile
99 }
100
101 do_stage () {
102         :
103 }
104
105 do_install () {
106         oe_runmake 'PKG_DIR=${D}' install-all
107 }
108
109 #do_install () {
110 #       install -d ${D}${sbindir} ${D}${sysconfdir}/appWeb/lib \
111 #                  ${D}${libexecdir}/appWeb ${D}${libdir}
112 #       install -m 0755 appWeb/appWeb ${D}${sbindir}/
113 #       install -m 0644 appWeb/appWeb.conf ${D}${sysconfdir}/appWeb/
114 #       install -m 0755 bin/${APPWEB_OS}/* ${D}${libexecdir}/appWeb/
115 #       install -m 0755 lib/lib*.so* ${D}${sysconfdir}/appWeb/lib/
116 #}