]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/apr/apr-util_1.1.2.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / apr / apr-util_1.1.2.bb
1 DESCRIPTION = "Apache Portable Runtime (APR) companion library"
2 SECTION = "libs"
3 DEPENDS = "apr expat gdbm"
4 MAINTAINER = "Mustafa Yuecel <yuecelm@ee.ethz.ch>"
5 LICENSE = "Apache License, Version 2.0"
6
7 PR = "r0"
8
9 # apache mirrors?
10 SRC_URI = "http://mirror.switch.ch/mirror/apache/dist/apr/${P}.tar.gz"
11
12 EXTRA_OECONF = "--with-apr=${STAGING_BINDIR} --with-dbm=gdbm --with-gdbm=${STAGING_DIR}/${HOST_SYS} --with-expat=${STAGING_DIR}/${HOST_SYS}"
13
14 inherit autotools lib_package binconfig
15
16 do_configure() {
17   oe_runconf
18 }
19
20 do_stage() {
21   oe_libinstall -a -so -C .libs libaprutil-1 ${STAGING_LIBDIR}
22 }