]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/avahi/avahi_0.1.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / avahi / avahi_0.1.bb
1 DESCRIPTION = "Avahi implements the DNS-SD over Multicast DNS"
2 HOMEPAGE = "http://www.freedesktop.org/Software/Avahi"
3 LICENCE= "GPL"
4 DEPENDS = "expat libdaemon dbus-0.34"
5 RRECOMMENDS = "libnss-mdns"
6 SECTION = "net"
7 PRIORITY = "optional"
8
9 SRC_URI = "http://www.freedesktop.org/~lennart/avahi-0.1.tar.gz \
10            file://no-strict-ansi.patch;patch=1 \
11            file://avahi-glib.pc.patch;patch=1 \
12            file://avahi-test-memory-corruption.patch;patch=1 \
13            file://dbus-warn.patch;patch=1 \
14            file://resolving.patch;patch=1 \
15            file://static-services-protocol.patch;patch=1"
16
17 PACKAGES = "avahi-daemon libavahi-common libavahi-core libavahi-client avahi-dnsconfd libavahi-glib avahi-dev avahi-doc"
18
19 FILES_libavahi-common = "${libdir}/libavahi-common.so.*"
20 FILES_libavahi-core= "${libdir}/libavahi-core.so.*"
21 FILES_avahi-daemon = "${sbindir}/avahi-daemon \
22                       ${sysconfdir}/avahi/avahi-daemon.conf \
23                       ${sysconfdir}/avahi/services \
24                       ${sysconfdir}/dbus-1 \
25                       ${sysconfdir}/init.d/avahi-daemon \
26                       ${datadir}/avahi/introspection/*.introspect \
27                       ${datadir}/avahi/avahi-service.dtd"
28 FILES_libavahi-client = "${libdir}/libavahi-client.so.*"
29 FILES_avahi-dnsconfd = "${sbindir}/avahi-dnsconfd \
30                         ${sysconfdir}/avahi/avahi-dnsconfd.action \
31                         ${sysconfdir}/init.d/avahi-dnsconfd"
32 FILES_libavahi-glib = "${libdir}/libavahi-glib.so.*"
33
34 CONFFILES_avahi-daemon = "${sysconfdir}/avahi/avahi-daemon.conf"
35
36 EXTRA_OECONF = "--with-distro=debian --disable-gtk --disable-python"
37 inherit autotools
38 inherit update-rc.d
39
40 INITSCRIPT_PACKAGES = "avahi-daemon avahi-dnsconfd"
41 INITSCRIPT_NAME_avahi-daemon = "avahi-daemon"
42 INITSCRIPT_NAME_avahi-dnsconfd = "avahi-dnsconfd"
43
44 pkg_postinst_avahi-daemon () {
45         grep avahi /etc/passwd || adduser --disabled-password --system --home /var/run/avahi-daemon avahi
46 }
47
48 pkg_postrm_avahi-daemon () {
49         deluser avahi || true
50 }
51