]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/bazaar/bazaar_1.2.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / bazaar / bazaar_1.2.bb
1 # bazaar OE build file
2 # Copyright (C) 2005 Chris Larson <kergoth@handhelds.org>
3 # Released under the MIT license (see the COPYING file in this tree)
4 #
5 # NOTE:
6 #   * Does not have an LDFLAGS variable on its link lines, only the "libs"
7 #     variable, which makes it troublesome to add -L's to the link.  For now,
8 #     we cheat and pass it in CFLAGS.
9
10 DEPENDS += "neon"
11 DESCRIPTION = "bazaar is an implementation of GNU Arch in C, based on tla."
12 HOMEPAGE = "http://bazaar.canonical.com/"
13 LICENSE = "GPL"
14 MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
15 PRIORITY = "optional"
16 SECTION = "devel"
17 PR = "r2"
18 RDEPENDS_${PN} += "patch"
19 RSUGGESTS_${PN} += "gnupg"
20
21 SRC_URI = "http://bazaar.canonical.com/releases/src/bazaar_${PV}.tar.gz \
22            file://no_archive_format_guess_msg.patch;patch=1 \
23            file://import_dirarg.patch;patch=1"
24
25 S = "${WORKDIR}/thelove@canonical.com---dists--bazaar--1.2"
26 B = "${WORKDIR}/build-${HOST_SYS}"
27
28 CFLAGS += "-I${B} -I${S}/src -I${S}/src/baz"
29 EXTRA_OEMAKE = "'CC=${CC}' \
30                 'CFLAGS=${CFLAGS} ${LDFLAGS}' \
31                 \
32                 'test-scripts=' \
33                 'test-progs=' \
34                 'prefix=${D}${prefix}' \
35                 'program-install-dir=${D}${bindir}' \
36                 'cgi-install-dir=${D}${libdir}/cgi' \
37                 'library-install-dir=${D}${libdir}' \
38                 'include-install-dir=${D}${includedir}/$(thispath)' \
39                 'etc-install-dir=${D}${sysconfdir}' \
40                 'libexec-install-dir=${D}${libexecdir}' \
41                 'info-install-dir=${D}${infodir}' \
42                 'man-install-dir=${D}${mandir}' \
43                 'scm-install-dir=${D}${datadir}/scheme' \
44                 'doc-install-dir=${D}${docdir}/$(thispath)' \
45                 'data-install-dir=${D}${datadir}/$(thispath)' \
46                 'locale-install-dir=${D}${datadir}/locale'"
47 PARALLEL_MAKE = ""
48
49
50 do_configure () {
51         ${S}/src/configure ${CONFARGS}
52
53 }
54
55 do_compile () {
56         oe_runmake
57 }
58
59 do_install () {
60         oe_runmake install-all
61         sed -e 's,^#!.*$$,#!/usr/bin/gawk -f,' ${S}/src/baz/=gpg-check.awk > \
62                 ${D}${bindir}/bazaar-gpg-check
63 }