]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/bluez/bluez-utils_3.4.bb
updated familiar to use dbus 0.94. That caused also the update of modules using DBUS...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / bluez / bluez-utils_3.4.bb
1 DESCRIPTION = "Linux Bluetooth Stack Userland Utilities."
2 SECTION = "console"
3 PRIORITY = "optional"
4 DEPENDS = "bluez-libs-${PV} dbus"
5 PROVIDES = "bluez-utils-dbus"
6 RPROVIDES_${PN} = "bluez-pan bluez-sdp bluez-utils-dbus"
7 RREPLACES = "bluez-utils-dbus"
8 RCONFLICTS_${PN} = "bluez-utils-nodbus"
9 LICENSE = "GPL"
10 PR = "r1"
11
12 SRC_URI = "http://bluez.sourceforge.net/download/bluez-utils-${PV}.tar.gz \
13         file://hcid.conf \
14         file://02dtl1_cs.sh \
15         file://hciattach-ti-bts.patch;patch=1"
16
17 # Almost all serial CF cards w/ manfid 0x0000,0x0000 seem to use the bcs protocol
18 # Let's default to that instead of 'any' until further notice...
19 SRC_URI += " file://default-manfid-0x0-to-bcps.patch;patch=1"
20
21 S = "${WORKDIR}/bluez-utils-${PV}"
22
23 EXTRA_OECONF = "--enable-initscripts --enable-bcm203x --enable-hid2hci"
24 #  --enable-obex           enable OBEX support
25 #  --enable-alsa           enable ALSA support
26 #  --enable-cups           install CUPS backend support
27 #  --enable-bccmd          install BCCMD interface utility
28 #  --enable-avctrl         install Audio/Video control utility
29 #  --enable-hid2hci        install HID mode switching utility
30 #  --enable-dfutool        install DFU firmware upgrade utility
31
32 inherit autotools update-rc.d
33
34 INITSCRIPT_NAME = "bluetooth"
35 INITSCRIPT_PARAMS = "defaults 23 19"
36
37 do_install_append() {
38         install -d ${D}${base_sbindir} ${D}${base_bindir}/  ${D}${sysconfdir}/apm/event.d/
39         mv ${D}${sbindir}/* ${D}${base_sbindir}/
40         mv ${D}${bindir}/* ${D}${base_bindir}/
41         rmdir ${D}${bindir} ${D}${sbindir}
42         chmod u+s ${D}${base_sbindir}/hciattach ${D}${base_sbindir}/hciconfig
43         install -m 0644 ${WORKDIR}/hcid.conf ${D}${sysconfdir}/bluetooth/
44         install -m 0755 ${WORKDIR}/02dtl1_cs.sh ${D}${sysconfdir}/apm/event.d/
45 }
46
47 CONFFILES_${PN} = "${sysconfdir}/bluetooth/hcid.conf ${sysconfdir}/bluetooth/rfcomm.conf \
48         ${sysconfdir}/default/bluetooth"
49
50 PACKAGES =+ "${PN}-ciptool"
51 FILES_${PN}-ciptool = "/bin/ciptool"
52 RREPLACES_${PN}-ciptool = "bluez-utils-dbus-ciptool"
53 RCONFLICTS_${PN}-ciptool = "bluez-utils-dbus-ciptool bluez-utils-nodbus"