]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/bochs/bochs_2.1.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / bochs / bochs_2.1.bb
1 DESCRIPTION = "x86 Emulator based on SDL"
2 SECTION = "base"
3 PRIORITY = "optional"
4 DEPENDS = "libsdl-qpe"
5 LICENSE = "GPL"
6
7 SRC_URI = "${SOURCEFORGE_MIRROR}/bochs/bochs-${PV}.tar.gz \
8            file://compile.patch;patch=1"
9
10 inherit autotools 
11
12 EXTRA_OECONF = "--without-x                 \
13                 --without-x11               \
14                 --without-beos              \
15                 --without-win32             \
16                 --without-macos             \
17                 --without-carbon            \
18                 --without-nogui             \
19                 --without-term              \
20                 --without-rfb               \
21                 --without-amigaos           \
22                 --with-sdl                  \
23                 --without-svga              \
24                 --without-wx"
25
26 do_compile() {
27         oe_runmake bochs bximage bxcommit
28 }
29
30 do_install() {
31         oe_runmake -i install # yes, ugly i know... but i can't get rid of that bailing out docbook crap atm.
32 }