]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/boost/boost-jam-native_3.1.10.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / boost / boost-jam-native_3.1.10.bb
1 # The Boost web site provides free peer-reviewed portable
2 # C++ source libraries. The emphasis is on libraries which
3 # work well with the C++ Standard Library. The libraries are
4 # intended to be widely useful, and are in regular use by
5 # thousands of programmers across a broad spectrum of applications.
6 DESCRIPTION = "Make system for boost (native)"
7 HOMEPAGE = "http://www.boost.org/"
8 MAINTAINER = "John Bowler <jbowler@acm.org>"
9 SECTION = "devel"
10 PRIORITY = "optional"
11 LICENSE = "Boost Software License"
12 PR = "r0"
13
14 SRC_URI = "${SOURCEFORGE_MIRROR}/boost/boost-jam-${PV}.tgz"
15 S = "${WORKDIR}/boost-jam-${PV}"
16
17 inherit native
18
19 do_compile() {
20         set -ex
21         rm -rf bin.*
22         ./build.sh gcc
23 }
24
25 # This is too terrible - the build script doesn't give any good
26 # way I can see to find out where the binaries are placed, so
27 # rely on only one bin.foo directory being created.
28 do_stage() {
29         set -ex
30         install -c -m 755 bin.*/jam ${STAGING_BINDIR}/
31         install -c -m 755 bin.*/mkjambase ${STAGING_BINDIR}/
32         install -c -m 755 bin.*/yyacc ${STAGING_BINDIR}/
33         rm -f ${STAGING_BINDIR}/bjam
34         ln -sf ./jam ${STAGING_BINDIR}/bjam
35 }