]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/boost/boost_1.32.0.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / boost / boost_1.32.0.bb
1 # The Boost web site provides free peer-reviewed portable
2 # C++ source libraries. The emphasis is on libraries which
3 # work well with the C++ Standard Library. The libraries are
4 # intended to be widely useful, and are in regular use by
5 # thousands of programmers across a broad spectrum of applications.
6 DESCRIPTION = "Free peer-reviewed portable C++ source libraries"
7 HOMEPAGE = "http://www.boost.org/"
8 MAINTAINER = "John Bowler <jbowler@acm.org>"
9 SECTION = "libs"
10 DEPENDS = "boost-jam-native"
11 PRIORITY = "optional"
12 LICENSE = "Boost Software License"
13 PR = "r1"
14
15 # need debian package naming for the libs
16 inherit debian
17
18 BOOST_VER = "${@"_".join(bb.data.getVar("PV",d,1).split("."))}"
19 BOOST_MAJ = "${@"_".join(bb.data.getVar("PV",d,1).split(".")[0:2])}"
20 BOOST_P = "boost_${BOOST_VER}"
21 SRC_URI = "${SOURCEFORGE_MIRROR}/boost/${BOOST_P}.tar.bz2 \
22                 file://unit_test_log10f.patch;patch=1 \
23                 file://linux-uclibc.patch;patch=1 \
24                 "
25
26 S = "${WORKDIR}/${BOOST_P}"
27
28 # Make a package for each library, plus -dev and -python
29 PACKAGES =
30
31 PACKAGES += "boost-date-time"
32 FILES_boost-date-time = "${libdir}/libboost_date_time.so.${PV}"
33
34 PACKAGES += "boost-filesystem"
35 FILES_boost-filesystem = "${libdir}/libboost_filesystem.so.${PV}"
36
37 PACKAGES += "boost-prg-exec-monitor"
38 FILES_boost-prg-exec-monitor = "${libdir}/libboost_prg_exec_monitor.so.${PV}"
39
40 PACKAGES += "boost-program-options"
41 FILES_boost-program-options = "${libdir}/libboost_program_options.so.${PV}"
42
43 PACKAGES += "boost-regex"
44 FILES_boost-regex = "${libdir}/libboost_regex.so.${PV}"
45
46 PACKAGES += "boost-signals"
47 FILES_boost-signals = "${libdir}/libboost_signals.so.${PV}"
48
49 PACKAGES += "boost-test-exec-monitor"
50 FILES_boost-test-exec-monitor = "${libdir}/libboost_test_exec_monitor.so.${PV}"
51
52 PACKAGES += "boost-thread-mt"
53 FILES_boost-thread-mt = "${libdir}/libboost_thread-mt.so.${PV}"
54
55 PACKAGES += "boost-unit-test-framework"
56 FILES_boost-unit-test-framework = "${libdir}/libboost_unit_test_framework.so.${PV}"
57
58 # Python - remove this and set:
59 #PYTHON_ROOT = "/dev/null"
60 # to remove the python build
61 DEPENDS += "python"
62 PYTHON_ROOT = "${STAGING_DIR}/${HOST_SYS}"
63 PYTHON_VERSION = "2.4"
64
65 PACKAGES += "boost-python"
66 FILES_boost-python = "${libdir}/libboost_python.so.${PV}"
67
68 # -dev last to pick up the remaining stuff
69 PACKAGES += "${PN}-dev"
70 FILES_${PN}-dev = "${includedir} ${libdir}/libboost_*.so ${libdir}/libboost_*.a"
71
72 # Oh yippee, a new build system, it's sooo cooool I could eat my own
73 # foot.  inlining=on lets the compiler choose, I think.  At least this
74 # stuff is documented...
75 # NOTE: if you leave <debug-symbols>on then in a debug build the build sys
76 # objcopy will be invoked, and that won't work.  Building debug apparently
77 # requires hacking gcc-tools.jam
78 #
79 # Sometimes I wake up screaming.  Famous figures are gathered in the nightmare,
80 # Steve Bourne, Larry Wall, the whole of the ANSI C committee.  They're just
81 # standing there, waiting, but the truely terrifying thing is what they carry
82 # in their hands.  At first sight each seems to bear the same thing, but it is
83 # not so for the forms in their grasp are ever so slightly different one from
84 # the other.  Each is twisted in some grotesque way from the other to make each
85 # an unspeakable perversion impossible to perceive without the onset of madness.
86 # True insanity awaits anyone who perceives all of these horrors together.
87 #
88 # Quotation marks, there might be an easier way to do this, but I can't find
89 # it.  The problem is that the user.hpp configuration file must receive a
90 # pre-processor macro defined as the appropriate string - complete with "'s
91 # around it.  (<> is a possibility here but the danger to that is that the
92 # failure case interprets the < and > as shell redirections, creating 
93 # random files in the source tree.)
94 #
95 #bjam: '-DBOOST_PLATFORM_CONFIG=\"config\"'
96 #do_compile: '-sGCC=... '"'-DBOOST_PLATFORM_CONFIG=\"config\"'"
97 SQD = '"'
98 EQD = '\"'
99 #boost.bb:   "...  '-sGCC=... '${SQD}'-DBOOST_PLATFORM_CONFIG=${EQD}config${EQD}'${SQD} ..."
100 BJAM_CONF = "${SQD}'-DBOOST_PLATFORM_CONFIG=${EQD}boost/config/platform/${TARGET_OS}.hpp${EQD}'${SQD}"
101
102 BJAM_TOOLS   = "-sTOOLS=gcc \
103                 '-sGCC=${CC} '${BJAM_CONF} \
104                 '-sGXX=${CXX} '${BJAM_CONF} \
105                 -sBUILD='release <optimization>space <inlining>on <debug-symbols>off' \
106                 '-sPYTHON_VERSION=${PYTHON_VERSION}' \
107                 --layout=system \
108                 "
109
110 BJAM_OPTS    = '${BJAM_TOOLS} \
111                 --builddir=${S}/${TARGET_SYS} \
112                 --with-python-root=${PYTHON_ROOT} \
113                 ${BJAM_EXTRA}'
114
115
116 do_compile() {
117         set -ex
118         bjam ${BJAM_OPTS} --prefix=${prefix} \
119                 --exec-prefix=${exec_prefix} \
120                 --libdir=${libdir} \
121                 --includedir=${includedir}
122 }
123
124 do_stage() {
125         set -ex
126         bjam ${BJAM_OPTS} \
127                 --libdir=${STAGING_LIBDIR} \
128                 --includedir=${STAGING_INCDIR} \
129                 install
130 }
131
132 do_install() {
133         set -ex
134         bjam ${BJAM_OPTS} \
135                 --libdir=${D}${libdir} \
136                 --includedir=${D}${includedir} \
137                 install
138 }