]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/brickout/brickout_2002.06.09.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / brickout / brickout_2002.06.09.bb
1 DESCRIPTION = "Clone of the classic arcade game Asteroids for Qt/Embedded based palmtop environments w/ SDL"
2 SECTION = "opie/games"
3 PRIORITY = "optional"
4 MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
5 LICENSE = "GPL"
6 DEPENDS = "libsdl-qpe libsdl-mixer libsdl-image"
7 PR = "r4"
8
9 SRC_URI = "ftp://ftp.billsgames.com/unix/agenda/brickout/src/brickout-${PV}.tar.gz \
10            file://directories.patch;patch=1"
11
12 inherit palmtop
13
14 EXTRA_QMAKEVARS_POST += " INCLUDEPATH+=${STAGING_INCDIR}/SDL LIBS+=-lSDL LIBS+=-lSDL_mixer LIBS+=-lSDLmain \
15                         LIBS+=-lSDL_image LIBS+=-lpthread TARGET=brickout DEFINES+=USE_SDL "
16
17 do_configure_prepend() {
18         qmake -project -o brickout.pro
19 }
20
21 do_install() {
22         install -d ${D}${palmtopdir}/bin \
23                    ${D}${palmtopdir}/apps/Games \
24                    ${D}${palmtopdir}/pics \
25                    ${D}${palmtopdir}/share/brickout/sounds \
26                    ${D}${palmtopdir}/share/brickout/music \
27                    ${D}${palmtopdir}/share/brickout/images
28         install -D -m 0755 brickout ${D}${palmtopdir}/bin/brickout
29         install -D -m 0644 brickout.png ${D}${palmtopdir}/pics/brickout.png
30
31         cp -pPR sounds/* ${D}${palmtopdir}/share/brickout/sounds/
32         cp -pPR music/* ${D}${palmtopdir}/share/brickout/music/
33         cp -pPR images-sdl/* ${D}${palmtopdir}/share/brickout/images/
34
35         echo "[Desktop Entry]" >${D}${palmtopdir}/apps/Games/brickout.desktop
36         echo "Comment=Arkanoid game" >>${D}${palmtopdir}/apps/Games/brickout.desktop
37         echo "Exec=brickout" >>${D}${palmtopdir}/apps/Games/brickout.desktop
38         echo "Icon=brickout" >>${D}${palmtopdir}/apps/Games/brickout.desktop
39         echo "Type=Application" >>${D}${palmtopdir}/apps/Games/brickout.desktop
40         echo "Name=Brickout" >>${D}${palmtopdir}/apps/Games/brickout.desktop
41 }