]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/chillispot/chillispot_0.98.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / chillispot / chillispot_0.98.bb
1 DESCRIPTION = "ChilliSpot is an open source captive portal or wireless LAN access point controller. It is used for authenticating users of a wireless LAN."
2 HOMEPAGE = "http://www.chillispot.org/"
3 MAINTAINER = "Bruno Randolf <bruno.randolf@4g-systems.biz>"
4 LICENSE = "GPL"
5 PR = "r1"
6
7 SRC_URI = "http://www.chillispot.org/download/chillispot-${PV}.tar.gz \
8         file://init"
9 RRECOMMENDS = "kernel-module-tun"
10
11 inherit autotools
12
13 do_install_append() {
14         install -d ${D}${sysconfdir} ${D}${sysconfdir}/init.d
15         install ${S}/doc/chilli.conf ${D}${sysconfdir}
16         install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/chillispot
17 }
18
19 CONFFILES_${PN}_nylon = "${sysconfdir}/chilli.conf"