]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/chillispot/chillispot_1.0RC3.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / chillispot / chillispot_1.0RC3.bb
1 DESCRIPTION = "ChilliSpot is an open source captive portal or wireless LAN access point controller. It is used for authenticating users of a wireless LAN."
2 HOMEPAGE = "http://www.chillispot.org/"
3 MAINTAINER = "Bruno Randolf <bruno.randolf@4g-systems.biz>"
4 LICENSE = "GPL"
5 SRC_URI = "http://www.chillispot.org/download/chillispot-${PV}.tar.gz \
6         file://init"
7 RDEPENDS = "kernel-module-tun"
8
9 inherit autotools
10
11 do_install_append() {
12         install -d ${D}/${sysconfdir} ${D}/${sysconfdir}/init.d
13         install ${S}/doc/chilli.conf ${D}/${sysconfdir}
14         install -m 755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/chillispot
15 }
16
17 CONFFILES_${PN}_nylon = "${sysconfdir}/chilli.conf"