]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/classpath/classpath_0.14.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / classpath / classpath_0.14.bb
1 DESCRIPTION = "GNU Classpath standard Java libraries"
2 HOMEPAGE = "http://www.gnu.org/software/classpath/"
3 LICENSE = "Classpath"
4 PRIORITY = "optional"
5 MAINTAINER = "Rene Wagner <rw@handhelds.org>"
6 SECTION = "libs"
7 PR = "r1"
8
9 DEPENDS = "glib-2.0 gtk+ libart-lgpl pango xtst jikes-native zip-native"
10 RDEPENDS_${PN} = "${PN}-common (${PV})"
11
12 SRC_URI = "${GNU_MIRROR}/${PN}/${P}.tar.gz \
13            file://disable-automake-checks.patch;patch=1"
14
15 inherit autotools
16
17 EXTRA_OECONF = "--with-jikes"
18
19 PACKAGES += " ${PN}-common ${PN}-examples"
20
21 FILES_${PN} = "${libdir}/${PN}"
22 FILES_${PN}-common = "${datadir}/${PN}/glibj.zip"
23 FILES_${PN}-examples = "${datadir}/${PN}/examples"
24
25 do_stage() {
26         install -d ${STAGING_INCDIR}/classpath
27         install -m 0755 include/jni* ${STAGING_INCDIR}/classpath/
28 }
29
30 do_install() {
31         autotools_do_install
32         mv ${D}${libdir}/security ${D}${libdir}/${PN}
33 }