]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/classpath/classpath_0.90.bb
4b4647f9740054c8d5c3c81c30f836c12877454b
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / classpath / classpath_0.90.bb
1 DESCRIPTION = "GNU Classpath standard Java libraries"
2 HOMEPAGE = "http://www.gnu.org/software/classpath/"
3 LICENSE = "Classpath"
4 PRIORITY = "optional"
5 MAINTAINER = "Rene Wagner <rw@handhelds.org>"
6 SECTION = "libs"
7
8 DEPENDS = "glib-2.0 gtk+ libart-lgpl pango xtst jikes-native zip-native"
9 RDEPENDS_${PN} = "${PN}-common (>= ${PV})"
10
11 SRC_URI = "${GNU_MIRROR}/${PN}/${P}.tar.gz \
12            file://disable-automake-checks.patch;patch=1"
13
14 inherit autotools
15
16 EXTRA_OECONF = "--with-jikes --disable-alsa"
17
18 PACKAGES += " ${PN}-common ${PN}-examples"
19
20 FILES_${PN} = "${libdir}/${PN}"
21 FILES_${PN}-common = "${datadir}/${PN}/glibj.zip"
22 FILES_${PN}-examples = "${datadir}/${PN}/examples"
23
24 do_stage() {
25         install -d ${STAGING_INCDIR}/classpath
26         install -m 0755 include/jni* ${STAGING_INCDIR}/classpath/
27 }
28
29 do_install() {
30         autotools_do_install
31         mv ${D}${libdir}/security ${D}${libdir}/${PN}
32 }