]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/clucene/clucene_0.8.12-pre.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / clucene / clucene_0.8.12-pre.bb
1 DESCRIPTION = "CLucene is a C++ port of Lucene: the high-performance, full-featured text search engine written in Java."
2 SECTION = "libs"
3 LICENSE = "LGPL"
4 PRIORITY = "optional"
5 CVSDATE = "20040704"
6 SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/clucene;module=. \
7            file://compile-fix.patch;patch=1"
8 S = "${WORKDIR}"
9
10 inherit autotools 
11
12 do_stage() {
13         oe_libinstall -C src libclucene ${STAGING_LIBDIR}
14         install -d ${STAGING_INCDIR}/CLucene/
15         install src/CLucene.h ${STAGING_INCDIR}/CLucene/
16         cd src
17         headers=`find . -name "*.h"`
18         for f in $headers
19         do
20                 install -d ${STAGING_INCDIR}/`dirname $f`
21                 install -m 0644 $f ${STAGING_INCDIR}/$f
22         done
23         echo > ${STAGING_INCDIR}/CLucene/util/dirent.h
24 }