]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/console-tools/console-tools_0.3.2.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / console-tools / console-tools_0.3.2.bb
1 SECTION = "base"
2 LICENSE = "GPL"
3 DESCRIPTION = "Allows you to set-up and manipulate the Linux console."
4 PR = "r2"
5
6 SRC_URI = "${SOURCEFORGE_MIRROR}/lct/console-tools-${PV}.tar.gz \
7            file://codepage.patch;patch=1 \
8            file://configure.patch;patch=1 \
9            file://compile.patch;patch=1 \
10            file://kbdrate.patch;patch=1 \
11            file://config/*.m4"
12
13 export SUBDIRS = "fontfiletools vttools kbdtools screenfonttools contrib \
14                   examples po intl compat"
15
16 acpaths = "-I config"
17 do_configure_prepend () {
18         mkdir -p config
19         cp ${WORKDIR}/config/*.m4 config/
20 }
21
22 do_compile () {
23         oe_runmake -C lib
24         oe_runmake 'SUBDIRS=${SUBDIRS}'
25 }
26
27 inherit autotools 
28
29 do_install () {
30         autotools_do_install
31         mv ${D}${bindir}/chvt ${D}${bindir}/chvt.${PN}
32         mv ${D}${bindir}/deallocvt ${D}${bindir}/deallocvt.${PN}
33         mv ${D}${bindir}/openvt ${D}${bindir}/openvt.${PN}
34 }
35
36 pkg_postinst_${PN} () {
37         update-alternatives --install ${bindir}/chvt chvt chvt.${PN} 100
38         update-alternatives --install ${bindir}/deallocvt deallocvt deallocvt.${PN} 100
39         update-alternatives --install ${bindir}/openvt openvt openvt.${PN} 100
40 }
41
42 pkg_prerm_${PN} () {
43         update-alternatives --remove chvt chvt.${PN}
44         update-alternatives --remove deallocvt deallocvt.${PN}
45         update-alternatives --remove openvt openvt.${PN}
46 }
47