]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/cpio/cpio_2.5.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / cpio / cpio_2.5.bb
1 DESCRIPTION = "GNU cpio is a program to manage archives of files."
2 HOMEPAGE = "http://www.gnu.org/software/cpio/"
3 SECTION = "console"
4 LICENSE = "GPL"
5 MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
6 PR = "r3"
7
8 SRC_URI = "${GNU_MIRROR}/cpio/cpio-${PV}.tar.gz \
9            file://install.patch;patch=1"
10 S = "${WORKDIR}/cpio-${PV}"
11
12 inherit autotools
13
14 do_install () {
15         autotools_do_install
16         mv ${D}${libexecdir}/rmt ${D}${libexecdir}/rmt.${PN}
17 }
18
19
20 pkg_postinst_${PN} () {
21         update-alternatives --install ${libexecdir}/rmt rmt rmt.${PN} 50
22 }
23
24
25 pkg_prerm_${PN} () {
26         update-alternatives --remove rmt rmt.${PN}
27 }
28