]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/cpuspeed/cpuspeed_1.1.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / cpuspeed / cpuspeed_1.1.bb
1 DESCRIPTION = "Userspace cpufreq governor"
2 SECTION = "base"
3 PRIORITY = "optional"
4 LICENSE = "GPL"
5
6 SRC_URI = "http://carlthompson.net/dl/cpuspeed/cpuspeed-${PV}.tar.gz"
7 S = "${WORKDIR}/cpuspeed-${PV}"
8
9 FILES_${PN} = "/sbin/cpuspeed"
10
11 do_compile() {
12         ${CXX} ${TARGET_CXXFLAGS} ${LDFLAGS} -o cpuspeed cpuspeed.cc
13 }
14
15 do_install() {
16         install -d ${D}${base_sbindir}
17         install -m 0755 cpuspeed ${D}${base_sbindir}/cpuspeed
18 }
19