]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/cron/cron_3.0pl1.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / cron / cron_3.0pl1.bb
1 SECTION = "base"
2 DESCRIPTION = "Vixie cron."
3 LICENSE = "cron"
4 PR="r7"
5 DEPENDS += "install-native"
6
7 SRC_URI = "http://ibiblio.org/pub/Linux/system/daemons/cron/cron${PV}.tar.gz \
8            file://nonrootinstall.patch;patch=1 \
9            file://time.patch;patch=1 \
10            file://init"
11 S = "${WORKDIR}/cron${PV}"
12
13 INITSCRIPT_NAME = "cron"
14 INITSCRIPT_PARAMS = "defaults"
15 inherit update-rc.d
16
17 CFLAGS_append = " -I${S} -DSYS_TIME_H=0"
18 do_install () {
19         install -d ${D}${sbindir} ${D}${bindir}
20         install -d ${D}${sysconfdir}/init.d/
21         install -d ${D}/var/cron/tabs
22         install -c -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/cron
23         oe_runmake 'DESTDIR=${D}' install
24         chmod ugo+rx ${D}${sbindir}/* ${D}${bindir}/*
25 }
26 pkg_postinst() {
27         update-rc.d cron defaults 65
28 }
29
30 pkg_postrm() {
31         update-rc.d cron remove
32 }
33                 
34