]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/cumulus/cumulus_1.2.1.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / cumulus / cumulus_1.2.1.bb
1 DESCRIPTION = "A flightcomputer application for Qt/E based Palmtop Environments"
2 SECTION = "opie/applications"
3 PRIORITY = "optional"
4 MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
5 LICENSE = "GPL"
6 APPTYPE = "binary"
7 APPNAME = "cumulus"
8 APPDESKTOP = "${S}"
9 PR = "r0"
10
11 SRC_URI = "http://www.kflog.org/fileadmin/user_upload/cumulus_downloads/${PV}/cumulus-${PV}.src.tar.bz2"
12 S = "${WORKDIR}/cumulus_${PV}/cumulus"
13
14 inherit opie
15
16 export OE_QMAKE_LINK="${CXX}"
17 EXTRA_QMAKEVARS_POST = "INCLUDEPATH+=-I."
18
19 #
20 # nasty hack since cumulus doesn't obey the qmake standard which requires just one .pro file per directory
21 #
22 do_compile() {
23         echo "#define SHARP_PDA_WARNSOUND 4" >sharp_char.h
24         qmake -makefile -spec ${QMAKESPEC} -after ${EXTRA_QMAKEVARS_POST} cumulus.pro
25         oe_runmake
26         qmake -makefile -spec ${QMAKESPEC} -after ${EXTRA_QMAKEVARS_POST} gpsClient.pro 
27         oe_runmake
28 }
29
30 do_install() {
31         install -d ${D}${palmtopdir}/pics/mapicons \
32                    ${D}${palmtopdir}/pics/mapicons/small \
33                    ${D}${palmtopdir}/pics/mapicons/windarrows
34         install -m 0644 ../cumulus.png ${D}${palmtopdir}/pics/cumulus.png
35         install -m 0644 map-icons/*.png ${D}${palmtopdir}/pics/mapicons
36         install -m 0644 map-icons/*.xpm ${D}${palmtopdir}/pics/mapicons
37         install -m 0644 map-icons/small/*.png ${D}${palmtopdir}/pics/mapicons/small
38         install -m 0644 map-icons/small/*.xpm ${D}${palmtopdir}/pics/mapicons/small
39         install -m 0644 map-icons/windarrows/*.png ${D}${palmtopdir}/pics/mapicons/windarrows
40
41         install -m 0755 gpsClient ${D}${palmtopdir}/bin/
42 }