]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/cyrus-imapd/cyrus-imapd_2.2.12.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / cyrus-imapd / cyrus-imapd_2.2.12.bb
1 SECTION = "console/network"
2 DEPENDS = "cyrus-sasl db3"
3 LICENSE = "BSD"
4 PR = "r6"
5 DEPENDS += "install-native"
6
7 SRC_URI = "ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-imapd-${PV}.tar.gz \
8            file://autotools.patch;patch=1 \
9            file://tail.patch;patch=1 \
10            file://cyrus \
11            file://cyrus.conf_2.2 \
12            file://imapd.conf_2.2 \
13            file://volatiles \
14            "
15
16 inherit autotools update-rc.d
17
18 INITSCRIPT_NAME = "cyrus"
19 INITSCRIPT_PARAMS = "start 56 3 4 5 . stop 15 0 1 6 ."
20
21 EXTRA_OECONF = "--with-auth=unix \
22                 --without-perl \
23                 --without-snmp"
24
25 FILES_${PN} += "${prefix}/cyrus/bin"
26
27 # Target only, the db4 headers are in include/db4, so *prepend* this
28 # directory to the search path
29 TARGET_CPPFLAGS =+ "-I${STAGING_DIR}/${TARGET_SYS}/include/db4"
30
31 # All, lib/foo.c includes <config.h> from the top level directory and
32 # is natively compiled
33 BUILD_CPPFLAGS += " -I${S} -I${S}/et"
34
35 do_install_append () {
36         install -m 755 ${WORKDIR}/cyrus ${D}${sysconfdir}/init.d/cyrus
37         install -m 644 ${WORKDIR}/cyrus.conf_2.2 ${D}${sysconfdir}/cyrus.conf
38         install -m 644 ${WORKDIR}/imapd.conf_2.2 ${D}${sysconfdir}/imapd.conf
39         install -m 644 ${WORKDIR}/volatiles ${D}${sysconfdir}/default/volatiles/01_cyrus-imapd
40 }
41
42 pkg_postinst () {
43         /etc/init.d/populate-volatile.sh
44 }
45
46 pkg_postrm () {
47 }
48