]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/cyrus-imapd/cyrus-imapd_2.2.5.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / cyrus-imapd / cyrus-imapd_2.2.5.bb
1 SECTION = "console/network"
2 DEPENDS = "cyrus-sasl"
3 PR = "r1"
4 LICENSE = "BSD"
5
6 SRC_URI = "ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-imapd-${PV}.tar.gz \
7            file://autotools.patch;patch=1 \
8            file://tail.patch;patch=1"
9
10 inherit autotools
11
12 EXTRA_OECONF = "--with-auth=unix \
13                 --without-perl"
14
15 BUILD_CFLAGS += " -I${S} -I${S}/et"
16 #do_compile_prepend () {
17 #       cd lib
18 #       ccache arm-linux-gcc -L/home/kergoth/code/build-arm/tmp/staging/arm-linux/lib -Wl,-rpath-link,/home/kergoth/code/build-arm/tmp/staging/arm-linux/lib -o mkchartable mkchartable.o xmalloc.o assert.o
19 #       ${BUILD_CC} ${BUILD_CFLAGS} mkchartable.c -c -o mkchartable.o
20 #       ${BUILD_CC} ${BUILD_CFLAGS} xmalloc.c -c -o xmalloc.o
21 #       ${BUILD_CC} ${BUILD_CFLAGS} assert.c -c -o assert.o
22 #       ${BUILD_CC} ${BUILD_LDFLAGS} -o mkchartable mkchartable.o xmalloc.o assert.o
23 #       rm -f xmalloc.o assert.o mkchartable.o
24 #       cd ..
25 #}