]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/dash/dash_0.5.2.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / dash / dash_0.5.2.bb
1 DESCRIPTION = "The Debian Almquist Shell is a POSIX compliant shell that is much smaller than 'bash'."
2 PROVIDES = "virtual/sh"
3 LICENSE = "BSD GPL"
4 PR = "r1"
5
6 SRC_URI = "http://ftp.debian.org/debian/pool/main/d/dash/dash_${PV}.orig.tar.gz \
7         http://ftp.debian.org/debian/pool/main/d/dash/dash_${PV}-6.diff.gz;patch=1 \
8         file://makefile-build-cc.diff;patch=1"
9
10 inherit autotools
11
12 bindir = "/bin"
13 PREFIX="${bindir}"
14
15 # dont use update-alternatives class because since we are dealing with /bin/sh
16 # we need to do the remove in pkg_prerm where the /bin/sh link still points
17 # to something (postrm is a shell script)
18
19 ALTERNATIVE_NAME = "sh"
20 ALTERNATIVE_PATH = "${bindir}/dash"
21 ALTERNATIVE_PRIORITY = "10"
22 ALTERNATIVE_LINK = "${bindir}/${ALTERNATIVE_NAME}"
23
24 pkg_postinst() {
25 update-alternatives --install ${ALTERNATIVE_LINK} ${ALTERNATIVE_NAME} ${ALTERNATIVE_PATH} ${ALTERNATIVE_PRIORITY}
26 }
27
28 pkg_prerm() {
29 update-alternatives --remove ${ALTERNATIVE_NAME} ${ALTERNATIVE_PATH}
30 }