]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/dbus/dbus-native_0.94.bb
updated familiar to use dbus 0.94. That caused also the update of modules using DBUS...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / dbus / dbus-native_0.94.bb
1 SECTION = "base"
2 PR = "r0"
3 HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
4 DESCRIPTION = "message bus system for applications to talk to one another"
5 LICENSE = "GPL"
6
7 S = "${WORKDIR}/dbus-${PV}"
8 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/dbus"
9 DEPENDS = "glib-2.0-native libxml2-native expat-native"
10
11 SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
12            file://cross.patch;patch=1 \
13            file://tmpdir.patch;patch=1"
14
15 inherit autotools pkgconfig gettext native
16
17 EXTRA_OECONF = "--disable-qt  --disable-qt3 --disable-gtk --disable-tests \
18                 --disable-checks --disable-xml-docs --disable-doxygen-docs \
19                 --with-xml=expat --without-x"
20
21 do_stage () {
22         oe_runmake install
23         autotools_stage_all
24
25         # for dbus-glib-native introspection generation
26         install -d ${STAGING_DATADIR}/dbus
27         install -m 0644 bus/session.conf ${STAGING_DATADIR}/dbus/session.conf
28 }