]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/dbus/dbus-native_1.0.1.bb
dbus-1.0.1: big update due to changes in DBUS API. Affected packages are: bluez-libs...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / dbus / dbus-native_1.0.1.bb
1 DESCRIPTION = "message bus system for applications to talk to one another"
2 HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
3 LICENSE = "GPL"
4 SECTION = "base"
5
6 PR = "r0"
7
8 DEPENDS = "glib-2.0-native libxml2-native expat-native"
9
10
11 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/dbus-1.0.1"
12 SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
13            file://cross.patch;patch=1 \
14            "
15
16 inherit autotools pkgconfig gettext native
17
18 S = "${WORKDIR}/dbus-${PV}"
19
20 EXTRA_OECONF = "--disable-qt  --disable-qt3 --disable-gtk --disable-tests \
21                 --disable-checks --disable-xml-docs --disable-doxygen-docs \
22                 --with-xml=expat --without-x"
23
24 do_stage () {
25         oe_runmake install
26         autotools_stage_all
27
28         # for dbus-glib-native introspection generation
29         install -d ${STAGING_DATADIR}/dbus
30         install -m 0644 bus/session.conf ${STAGING_DATADIR}/dbus/session.conf
31 }