]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/dbus/dbus_0.94.bb
updated familiar to use dbus 0.94. That caused also the update of modules using DBUS...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / dbus / dbus_0.94.bb
1 #DEFAULT_PREFERENCE = "-1"
2
3 SECTION = "base"
4 HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
5 DESCRIPTION = "message bus system for applications to talk to one another"
6 LICENSE = "GPL"
7 DEPENDS = "expat glib-2.0 virtual/libintl"
8
9 SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
10            file://cross.patch;patch=1 \
11            file://tmpdir.patch;patch=1 \
12            file://dbus-1.init \
13            file://fix-segfault.patch;patch=1 \
14            file://fix-install-daemon.patch;patch=1"
15
16 inherit autotools pkgconfig update-rc.d gettext
17
18 INITSCRIPT_NAME = "dbus-1"
19 INITSCRIPT_PARAMS = "defaults"
20
21 CONFFILES_${PN} = "${sysconfdir}/dbus-1/system.conf ${sysconfdir}/dbus-1/session.conf"
22
23 FILES_${PN} = "${bindir}/dbus-daemon ${bindir}/dbus-launch ${bindir}/dbus-cleanup-sockets ${bindir}/dbus-send ${bindir}/dbus-monitor ${bindir}/dbus-uuidgen ${sysconfdir} ${datadir}/dbus-1/services ${libdir}/lib*.so.*"
24 FILES_${PN}-dev += "${libdir}/dbus-1.0/include"
25
26 pkg_postinst_dbus() {
27 #!/bin/sh
28
29 # can't do adduser stuff offline
30 if [ "x$D" != "x" ]; then
31   exit 1
32 fi
33
34 MESSAGEUSER=messagebus
35 MESSAGEHOME=/var/run/dbus
36
37 mkdir -p $MESSAGEHOME || true
38 chgrp "$MESSAGEUSER" "$MESSAGEHOME" 2>/dev/null || addgroup "$MESSAGEUSER"
39 chown "$MESSAGEUSER"."$MESSAGEUSER" "$MESSAGEHOME" 2>/dev/null || adduser --system --home "$MESSAGEHOME" --no-create-home --disabled-password --ingroup "$MESSAGEUSER" "$MESSAGEUSER"
40 dbus-uuidgen --ensure
41 }
42
43 EXTRA_OECONF = "--disable-qt  --disable-qt3 --disable-gtk --disable-tests \
44                 --disable-checks --disable-xml-docs --disable-doxygen-docs \
45                 --with-xml=expat --without-x"
46
47 do_stage () {
48         oe_libinstall -so -C dbus libdbus-1 ${STAGING_LIBDIR}
49
50         autotools_stage_includes
51
52         mkdir -p ${STAGING_LIBDIR}/dbus-1.0/include/dbus/
53         install -m 0644 dbus/dbus-arch-deps.h ${STAGING_LIBDIR}/dbus-1.0/include/dbus/
54 }
55
56 do_install_append () {
57         install -d ${D}${sysconfdir}/init.d
58         install -m 0755 ${WORKDIR}/dbus-1.init ${D}${sysconfdir}/init.d/dbus-1
59 }
60
61 python populate_packages_prepend () {
62         if (bb.data.getVar('DEBIAN_NAMES', d, 1)):
63                 bb.data.setVar('PKG_dbus', 'dbus-1', d)
64 }