]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/ddclient/ddclient_3.6.3.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / ddclient / ddclient_3.6.3.bb
1 SECTION = "console/network"
2 DESCRIPTION = "Ddclient is a Perl client used to update dynamic DNS entries for accounts on Dynamic DNS Network Services"
3 HOMEPAGE = "http://ddclient.sourceforge.net/"
4 MAINTAINER = "Bruno Randolf <bruno.randolf@4g-systems.biz>"
5 LICENSE = "GPL"
6
7 SRC_URI = "${SOURCEFORGE_MIRROR}/ddclient/ddclient-${PV}.tar.bz2 \
8         file://ip-up"
9
10 RDEPENDS = "perl perl-module-strict perl-module-getopt-long perl-module-vars perl-module-warnings-register perl-module-warnings perl-module-carp perl-module-exporter perl-module-constant perl-module-exporter-heavy perl-module-sys-hostname perl-module-xsloader perl-module-autoloader perl-module-io-socket perl-module-io-handle perl-module-symbol perl-module-selectsaver perl-module-io perl-module-socket perl-module-errno perl-module-config perl-module-io-socket-inet perl-module-io-socket-unix perl-module-integer"
11
12 do_install() {
13         install -d ${D}${sbindir} ${D}${sysconfdir} ${D}${sysconfdir}/init.d
14         install -d ${D}${sysconfdir}/ppp/ip-up.d/ install -d ${D}${docdir}/ddclient
15         install -m 755 ${S}/ddclient ${D}${sbindir}
16         install ${S}/sample-etc_ddclient.conf ${D}${sysconfdir}/ddclient.conf
17         install -m 755 ${WORKDIR}/ip-up ${D}${sysconfdir}/ppp/ip-up.d/ddclient
18         install -m 755 ${S}/sample-etc_rc.d_init.d_ddclient ${D}${sysconfdir}/init.d/ddclient
19         install ${S}/README* ${D}${docdir}/ddclient
20         install ${S}/COPY* ${D}${docdir}/ddclient
21         install ${S}/sample* ${D}${docdir}/ddclient
22 }
23
24 CONFFILES_${PN}_nylon = "${sysconfdir}/ddclient.conf"