]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/device-mapper/device-mapper_1.01.04.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / device-mapper / device-mapper_1.01.04.bb
1 SECTION = "libs"
2 DESCRIPTION = "The Device-mapper is a new component of the linux kernel \
3 that supports logical volume management. It is required by LVM2 and EVMS. \
4 The original LVM (included in stock 2.4 kernels) does not use it."
5 MAINTAINER = "Dan Williams <dan.j.williams@gmail.com>"
6 LICENSE = "GPL"
7 PR = "r2"
8
9 S = "${WORKDIR}/${PN}.${PV}"
10
11 SRC_URI = "ftp://sources.redhat.com/pub/dm/device-mapper.${PV}.tgz \
12            file://devmap-mknod-busybox.patch;patch=1"
13
14 inherit autotools update-rc.d
15
16 INITSCRIPT_NAME = "devmap_mknod.sh"
17 INITSCRIPT_PARAMS = "defaults"
18
19 do_stage () {
20         install -m 0644 lib/libdevmapper.h ${STAGING_INCDIR} || die "failed to install libdevmapper.h"
21         oe_libinstall -a -so -C lib/ioctl libdevmapper ${STAGING_LIBDIR}
22 }
23
24 do_install() {
25         autotools_do_install
26         oe_runmake install_static_lib
27         install -D -m 755 ${S}/scripts/${INITSCRIPT_NAME} ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
28 }