]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/dhcp-forwarder/dhcp-forwarder_0.7.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / dhcp-forwarder / dhcp-forwarder_0.7.bb
1 SECTION = "console/network"
2 DESCRIPTION = "This program is used to forward DHCP and BOOTP messages between two \
3  networks with different broadcast domains. \
4  It works better with ppp - and especially with ipsec over ppp - than \
5  dhcp-relay from ISC and has a smaller foot print."
6 HOMEPAGE = "http://www.nongnu.org/dhcp-fwd/"
7 MAINTAINER = "Bruno Randolf <bruno.randolf@4g-systems.biz>"
8 LICENSE = "GPLv2"
9  
10 SRC_URI = "http://savannah.nongnu.org/download/dhcp-fwd/dhcp-forwarder-${PV}.tar.bz2 \
11         file://init \
12         file://dhcp-fwd.cfg"
13
14 inherit autotools update-rc.d
15
16 EXTRA_OECONF="--disable-dietlibc"
17
18 INITSCRIPT_NAME="dhcp-forwarder"
19 INITSCRIPT_PARAMS="defaults"
20
21 do_install_append() {
22         install -d ${D}${sysconfdir}/init.d
23         install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/dhcp-forwarder
24         install -m 0644 ${WORKDIR}/dhcp-fwd.cfg ${D}${sysconfdir}
25 }
26
27 CONFFILES_${PN}_nylon = "${sysconfdir}/dhcp-fwd.cfg"