]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/diffstat/diffstat_1.39.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / diffstat / diffstat_1.39.bb
1 DESCRIPTION = "diffstat reads the output of diff and displays a histogram of \
2 the insertions, deletions, and modifications per-file. It is useful for \
3 reviewing large, complex patch files."
4 HOMEPAGE = "http://invisible-island.net/diffstat/"
5 MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
6 PRIORITY = "optional"
7 SECTION = "devel"
8
9 # NOTE: The upstream maintainer has a single 'diffstat.tar.gz' for the
10 # latest version of the package.  It could easily change out from under us.
11 # I'd rather rely on debian, and possible have the sources vanish, than risk
12 # the sources _changing_ underneith us. -CL
13 SRC_URI = "${DEBIAN_MIRROR}/main/d/diffstat/diffstat_${PV}.orig.tar.gz \
14            ${DEBIAN_MIRROR}/main/d/diffstat/diffstat_${PV}-1.diff.gz;patch=1"
15 S = "${WORKDIR}/diffstat-${PV}"
16
17 inherit autotools
18
19 do_configure () {
20         if [ ! -e acinclude.m4 ]; then
21                 mv aclocal.m4 acinclude.m4
22         fi
23         autotools_do_configure
24 }