]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/dillo/dillo2_0.6.6.bb
gnutls: bump PR. don't use _prepend for do_configure.
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / dillo / dillo2_0.6.6.bb
1 SECTION = "x11/network"
2 DESCRIPTION = "Lightweight gtk+2 browser."
3 LICENSE = "GPL"
4 PRIORITY = "optional"
5 PR = "r2"
6
7 DEPENDS = "gtk+"
8 RDEPENDS = "gdk-pixbuf-loader-xpm"
9
10 SRC_URI="http://www.dillo.org/download/dillo-${PV}.tar.gz \
11          file://gtk2.patch;patch=1;pnum=1 \
12          file://fix_about_syntax.patch;patch=1;pnum=1 \
13          file://no-title-prefix.patch;patch=1;pnum=1 \
14          file://dillo.desktop \
15          file://dillo.png \
16          file://dillorc"
17
18 S = "${WORKDIR}/dillo-${PV}/"
19
20 inherit autotools pkgconfig
21
22 do_install() {
23         install -d ${D}${bindir}
24         install -d ${D}${datadir}/applications
25         install -d ${D}${datadir}/pixmaps
26         install -d ${D}${sysconfdir}
27         install -m 0644 ${WORKDIR}/dillo.desktop ${D}${datadir}/applications/dillo.desktop
28         install -m 0644 ${WORKDIR}/dillo.png ${D}${datadir}/pixmaps/dillo.png
29         install -m 0755 ${S}/src/dillo ${D}${bindir}/dillo
30         install -m 0644 ${WORKDIR}/dillorc ${D}${sysconfdir}/dillorc
31 }