]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/driftnet/driftnet_0.1.6.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / driftnet / driftnet_0.1.6.bb
1 DESCRIPTION = "Driftnet watches network traffic, and picks out and displays JPEG and GIF \
2 images for display. It is an horrific invasion of privacy and shouldn't be used \
3 by anyone anywhere. It can also extract MPEG audio data from the network and \
4 play it."
5 MAINTAINER = "Simon Pickering <S.G.Pickering@bath.ac.uk>"
6 SECTION = "net"
7 PRIORITY = "optional"
8
9 DEPENDS = "libpcap jpeg libungif gtk+ libgpewidget"
10 PV = "0.1.6"
11
12 SRC_URI = "http://www.ex-parrot.com/~chris/driftnet/${PN}-${PV}.tar.gz \
13         file://arm.patch;patch=1"
14
15 S = "${WORKDIR}/driftnet-${PV}"
16
17 inherit autotools
18
19 do_compile() {
20         oe_runmake STAGING_INCDIR="${STAGING_INCDIR}"
21 }
22
23 do_install() {
24         install -d ${D}/${bindir}
25         install -m 0744 driftnet ${D}/${bindir}/
26 }