]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/e17/e-wm_0.16.999.023.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / e17 / e-wm_0.16.999.023.bb
1 DESCRIPTION = "E17 - the Enlightenment Window Mananger"
2 DEPENDS = "evas-x11 ecore-x11 edje eet embryo e"
3 LICENSE = "MIT"
4 SECTION = "e/apps"
5 MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
6 PR = "r3"
7
8 SRC_URI = "http://enlightenment.freedesktop.org/files/enlightenment-${PV}.tar.gz \
9            file://fix-configure.patch;patch=1 \
10            file://remove-large-fonts.patch;patch=1 \
11            file://Xsession.d/98enlightenment"
12            
13 #           cvs://anonymous@thinktux.net/root;module=e17/apps/e/data/themes;date=20050926"
14 #           file://disable-splash.patch;patch=1 \
15 #           http://cvs.sourceforge.net/viewcvs.py/*checkout*/enlightenment/e17/apps/e/data/themes/default_entry.edc?rev=1.1 \
16 #           http://cvs.sourceforge.net/viewcvs.py/*checkout*/enlightenment/e17/apps/e/data/themes/images/focus.png?rev=1.1 \
17 #           http://cvs.sourceforge.net/viewcvs.py/*checkout*/enlightenment/e17/apps/e/data/themes/images/entry.png?rev=1.1 \
18 #           http://cvs.sourceforge.net/viewcvs.py/*checkout*/enlightenment/e17/apps/e/data/themes/images/entry_focus.png?rev=1.1"
19         
20
21 S = "${WORKDIR}/enlightenment-${PV}"
22
23 inherit autotools
24
25 PROFILE = "LORES_PDA"
26 PROFILE_c7x0 = "HIRES_PDA"
27 PROFILE_tosa = "HIRES_PDA"
28 PROFILE_spitz = "HIRES_PDA"
29 PROFILE_akita = "HIRES_PDA"
30
31 EXTRA_OECONF = "--with-profile=${PROFILE} \
32                 --with-edje-cc=${STAGING_BINDIR}/edje_cc \
33                 --x-includes=${STAGING_INCDIR}/X11 \
34                 --x-libraries=${STAGING_LIBDIR}"
35
36 FILES_${PN} = "${bindir}/* ${libdir}/* ${datadir} ${sysconfdir}"
37
38 do_compile_prepend() {
39         find ${S} -name Makefile | xargs sed -i 's:/usr/include:${STAGING_INCDIR}:'
40         find ${S} -name Makefile | xargs sed -i 's:/usr/X11R6/include:${STAGING_INCDIR}:'
41 #       mv "${WORKDIR}/themes/default_entry.edc" "${S}/data/themes/"
42 #       mv "${WORKDIR}/themes/images/focus.png" "${S}/data/themes/images/"
43 #       mv "${WORKDIR}/themes/images/entry.png" "${S}/data/themes/images/"
44 #       mv "${WORKDIR}/themes/images/entry_focus.png" "${S}/data/themes/images/"
45 }
46
47 do_install_append() {
48         install -d ${D}/${sysconfdir}/X11/Xsession.d
49         install -m 755 ${WORKDIR}/Xsession.d/98enlightenment ${D}/${sysconfdir}/X11/Xsession.d
50 }