]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/e2fsprogs/e2fsprogs-native_1.38.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / e2fsprogs / e2fsprogs-native_1.38.bb
1 SECTION = "base"
2 include e2fsprogs_${PV}.bb
3 inherit native
4
5 FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/e2fsprogs-${PV}', '${FILE_DIRNAME}/e2fsprogs', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
6 PACKAGES = ""
7 DEPENDS = ""
8
9 do_stage () {
10         oe_libinstall -a -C lib libe2p ${STAGING_LIBDIR}/
11         oe_libinstall -a -C lib libext2fs ${STAGING_LIBDIR}/
12         install -d ${STAGING_INCDIR}/e2p
13         for h in ${e2pheaders}; do
14                 install -m 0644 lib/e2p/$h ${STAGING_INCDIR}/e2p/ || die "failed to install $h"
15         done
16         install -d ${STAGING_INCDIR}/ext2fs
17         for h in ${ext2fsheaders}; do
18                 install -m 0644 lib/ext2fs/$h ${STAGING_INCDIR}/ext2fs/ || die "failed to install $h"
19         done
20 }