]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/efl/emotion_0.0.1.004.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / efl / emotion_0.0.1.004.bb
1 DESCRIPTION = "Emotion is a multimedia library based on libxine"
2 LICENSE = "MIT"
3 DEPENDS = "eet virtual/evas edje virtual/ecore embryo virtual/libxine"
4 RDEPENDS += "libemotion-themes libemotion-plugins"
5 PR = "r2"
6
7 #FIXME: Needs patch not to build the examples when building against ecore-fb, because the examples depend on ecore-x11
8
9 inherit efl
10
11 PACKAGES += "emotion-plugins"
12 FILES_emotion-plugins = "${libdir}/xine/plugins/1.1.0/*.so ${libdir}/emotion/*.so"
13
14 do_compile_prepend() {
15         find ${S} -type f -name "*.[ch]" | xargs sed -i 's:NULL:0:g'
16 }