]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/efl/emotion_20060128.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / efl / emotion_20060128.bb
1 DESCRIPTION = "Emotion is a multimedia library based on libxine"
2 LICENSE = "MIT"
3 DEPENDS = "eet virtual/evas edje virtual/ecore embryo virtual/libxine"
4 RDEPENDS += "libemotion-themes libemotion-plugins"
5 PR = "r2"
6
7 #FIXME: Needs patch not to build the examples when building against ecore-fb, because the examples depend on ecore-x11
8 DEFAULT_PREFERENCE = "-1"
9
10 inherit efl
11
12 SRC_URI = "cvs://anonymous@thinktux.net/root;module=e17/libs/emotion;date=${PV}"
13 S = "${WORKDIR}/emotion"
14
15 PACKAGES += "emotion-plugins"
16 FILES_emotion-plugins = "${libdir}/xine/plugins/1.1.0/*.so ${libdir}/emotion/*.so"
17
18 do_compile_prepend() {
19         find ${S} -type f -name "*.[ch]" | xargs sed -i 's:NULL:0:g'
20 }