]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/emul/emul_1.0.5.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / emul / emul_1.0.5.bb
1 DESCRIPTION = "EarthMate Userland Library"
2 SECTION = "libs/network"
3 PRIORITY = "optional"
4 LICENSE = "GPL"
5 DEPENDS = "libusb ncurses"
6 PR = "r1"
7
8 SRC_URI = "http://download.berlios.de/emul/emul-${PV}.tar.gz"
9
10 CFLAGS += "-I${STAGING_INCDIR}"
11
12 do_compile() {
13         ${CC} -c ${CFLAGS} -D_REENTRANT -fPIC -o emul.o src/emul.c
14         ${CC} -c ${CFLAGS} -D_REENTRANT -fPIC -o buf.o src/buf.c
15         ${CC} ${LDFLAGS} -shared -fPIC -Wl,-soname,libemul.so.1 -o libemul.so -lusb -lpthread emul.o buf.o
16
17         ${CC} -c ${CFLAGS} -Isrc -o sirfmon.o src/sirfmon.c
18         ${CC} ${LDFLAGS} -L. -lemul -lncurses -lm sirfmon.o -o sirfmon
19 }
20
21 do_install() {
22         install -d ${D}${libdir}
23         oe_libinstall -so libemul ${D}${libdir}
24
25         install -d ${D}${bindir}
26         install -m 0755 sirfmon ${D}${bindir}
27 }
28
29 PACKAGES =+ "sirfmon"
30 SECTION_sirfmon = "network"
31 FILES_sirfmon = "${bindir}"
32 FILES_${PN} = "${libdir}"