]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/fastjar/fastjar-native_0.92+gcc3.4.2.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / fastjar / fastjar-native_0.92+gcc3.4.2.bb
1 DESCRIPTION = "jar replacement written in C."
2 HOMEPAGE = "http://sourceforge.net/projects/fastjar/"
3 SECTION = "devel"
4 PRIORITY = "optional"
5 LICENSE = "GPL"
6 MAINTAINER = "Rene Wagner <rw@handhelds.org>"
7
8 DEPENDS = "zlib"
9
10 GCC_VER = "${@bb.data.getVar('PV',d,1).split('gcc')[1]}"
11 SRC_URI = "${GNU_MIRROR}/gcc/gcc-${GCC_VER}/gcc-${GCC_VER}.tar.bz2"
12
13 S = "${WORKDIR}/gcc-${GCC_VER}"
14
15 inherit autotools native
16
17 EXTRA_OECONF = "--with-system-zlib --with-fastjar"
18
19 do_configure () {
20         gnu-configize || die "failure running gnu-configize"
21         oe_runconf
22 }
23
24 do_compile() {
25         oe_runmake maybe-all-fastjar
26 }
27
28 do_stage() {
29         install -d ${STAGING_BINDIR}
30         install -m 755 fastjar/jar ${STAGING_BINDIR}/fastjar
31         install -m 755 fastjar/grepjar ${STAGING_BINDIR}
32 }