]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/fastjar/fastjar-native_0.92+gcc3.4.4.bb
Add support for building java apps and libraries
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / fastjar / fastjar-native_0.92+gcc3.4.4.bb
1 # fastjar-native OE build file
2 # Copyright (C) 2006, Rene Wagner. All Rights Reserved
3 # Released under the MIT license (see org.handhelds.familiar/COPYING.MIT)
4
5 DESCRIPTION = "jar replacement written in C."
6 HOMEPAGE = "http://sourceforge.net/projects/fastjar/"
7 SECTION = "devel"
8 PRIORITY = "optional"
9 LICENSE = "GPL"
10 MAINTAINER = "Rene Wagner <rw@handhelds.org>"
11
12 DEPENDS = "zlib"
13
14 GCC_VER = "${@bb.data.getVar('PV',d,1).split('gcc')[1]}"
15 SRC_URI = "${GNU_MIRROR}/gcc/gcc-${GCC_VER}/gcc-${GCC_VER}.tar.bz2"
16
17 S = "${WORKDIR}/gcc-${GCC_VER}"
18
19 inherit autotools native
20
21 EXTRA_OECONF = "--with-system-zlib --with-fastjar"
22
23 do_configure () {
24         gnu-configize || die "failure running gnu-configize"
25         oe_runconf
26 }
27
28 do_compile() {
29         oe_runmake maybe-all-fastjar
30 }
31
32 do_stage() {
33         install -d ${STAGING_BINDIR}
34         install -m 755 fastjar/jar ${STAGING_BINDIR}/fastjar
35         install -m 755 fastjar/grepjar ${STAGING_BINDIR}
36 }