]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/ffmpeg/ffmpeg_0.4.9-pre1.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / ffmpeg / ffmpeg_0.4.9-pre1.bb
1
2 DESCRIPTION = "ffmpeg"
3 SECTION = "libs"
4 PRIORITY = "optional"
5 DEPENDS = "zlib libvorbis faad2 faac liba52 lame mplayer"
6 LICENSE = "LGPL"
7 PR = "r1"
8
9
10 inherit autotools
11
12 SRC_URI = "${SOURCEFORGE_MIRROR}/ffmpeg/ffmpeg-${PV}.tar.gz \
13         file://configure.patch;patch=0 \
14         file://common.patch;patch=1 \
15         file://soname.patch;patch=1 \
16         "
17
18 TARGET_LDFLAGS_append = " -lm -la52 "
19
20 EXTRA_OECONF=" \
21         --enable-mp3lame \
22         --enable-vorbis \
23         --enable-faad \
24         --enable-faadbin \
25         --enable-faac \
26         --enable-a52 \
27         --enable-a52bin \
28         --enable-pp \
29         --enable-shared-pp \
30         --enable-shared \
31         --disable-amr_nb \
32         --enable-amr_nb-fixed \
33         --disable-amr_wb \
34         --enable-pthreads \
35         --enable-gpl \
36         --enable-zlib \
37         \
38         --disable-audio-beos \
39         --disable-v4l \
40         --disable-dv1394 \
41         --disable-debug \
42         --disable-ffserver \
43         --disable-ffplay \
44         \
45         --cross-prefix=${TARGET_PREFIX} \
46         --extra-cflags=\$(TARGET_CFLAGS) \
47         --extra-ldflags=\$(TARGET_LDFLAGS) \
48         --extra-libs=\$(TARGET_LDFLAGS) \
49         \
50         --cpu=${PACKAGE_ARCH} \
51         --prefix=${D}${prefix} \
52         --mandir=${D}${prefix}/share/man \
53 "
54
55 PACKAGES += "libavcodec libavcodec-dev libavformat libavformat-dev"
56 FILES_${PN} = "${bindir}"
57 FILES_${PN}-dev = "${includedir}"
58 FILES_libavcodec = "${libdir}/libavcodec*.so.*"
59 FILES_libavcodec-dev = "${libdir}/libavcodec*.so ${libdir}/libavcodec*.la ${libdir}/libavcodec*.a"
60 FILES_libavformat = "${libdir}/libavformat*.so.*"
61 FILES_libavformat-dev = "${libdir}/libavformat*.so ${libdir}/libavformat*.la ${libdir}/libavformat*.a"
62
63 # We do this because the install program is called with -s which causes it to call "strip" and it then mangles cross compiled stuff..
64 PATH_prepend="${CROSS_DIR}/${TARGET_SYS}/bin:"
65
66 #       --enable-shared-pp \
67
68 do_configure_prepend() {
69         export CC="${CC}"
70 }
71
72 do_stage() {
73         oe_libinstall -a -so -C libavcodec libavcodec ${STAGING_LIBDIR}
74         oe_libinstall -a -so -C libavformat libavformat ${STAGING_LIBDIR}
75
76         install -d ${STAGING_INCDIR}/ffmpeg
77         install -m 0644 ${S}/libavcodec/avcodec.h ${STAGING_INCDIR}/ffmpeg/avcodec.h
78         install -m 0644 ${S}/libavcodec/common.h ${STAGING_INCDIR}/ffmpeg/common.h
79         install -m 0644 ${S}/libavcodec/rational.h ${STAGING_INCDIR}/ffmpeg/rational.h
80         install -m 0644 ${S}/libavformat/avformat.h ${STAGING_INCDIR}/ffmpeg/avformat.h
81         install -m 0644 ${S}/libavformat/avio.h ${STAGING_INCDIR}/ffmpeg/avio.h
82         install -m 0644 ${S}/libavformat/rtp.h ${STAGING_INCDIR}/ffmpeg/rtp.h
83         install -m 0644 ${S}/libavformat/rtsp.h ${STAGING_INCDIR}/ffmpeg/rtsp.h
84         install -m 0644 ${S}/libavformat/rtspcodes.h ${STAGING_INCDIR}/ffmpeg/rtspcodes.h
85 }